I ended up creating the encrypted volume under both Linux and OSX during some troubleshooting so here's how I did it in both OSs. Note: you only need to create the encrypted once in either Linux or OSX
The steps for Linux (Ubuntu 8.10):
- Install Truecrypt (grab the .deb and install that)
- truecrypt -t -c /dev/sdc (create the encrypted volume - choose "None" for the file system)
- truecrypt -t --filesystem=none /dev/sdc (mount the volume)
- mkfs.ntfs -f -L Cams_1Tb /dev/mapper/truecrypt1 (format the volume as ntfs)
The steps for OS X (Leopard):
- Install Truecrypt
- Install ntfs-3g for mac
- I also installed MacFuse 2.0 at one stage following on from some forums posts but this may not be necessary (Truecrypt 6.1a installs MacFuse 1.6 or 1.7)
- /Applications/TrueCrypt.app/Contents/MacOS/TrueCrypt -t --filesystem=fat -c /dev/rdisk2 (fat seemed to work better than no file system at all)
- Mount the Volume in Truecrypt and look at the "Volume Properties" on the newly attached volume. Take note of the "Virtual Device" in my case this was /dev/disk5
- sudo diskutil eraseVolume NTFS-3G Cams_1Tb /dev/disk5 (convert the FAT volume to NTFS)
nice, thanks for that!
ReplyDeleteThanks!
ReplyDelete